Ceci est une ancienne révision du document !


Que signifie l'erreur « Entering compatibility mode »?

  • Message: Entering compatibility mode
  • Origine: LaTeX.

You run your LaTeX job, and it starts by saying

Entering LaTeX 2.09 COMPATIBILITY MODE

followed by lines of asterisks and !!WARNING!! (avertissement complet ci-après).

This means that the document is not written in “current” LaTeX syntax, and that there is no guarantee that all parts of the document will be formatted correctly.

If the document is someone else's, and you want no more than a copy to read, ignore the error. The document may fail elsewhere, but as often as not it will provide a DVI or PDF file that's adequate for most purposes.

If it's a new document you have just started working on, you have been misled by someone. You have written something like:

\documentstyle{article}

or, more generally:

\documentstyle[options]{class}

These forms are (as the warning says) LaTeX 2.09 syntax, and to get rid of the warning, you must change the command.

The simple form is easy to deal with:

\documentstyle{article}

should become:

\documentclass{article}

The complex form is more difficult, since LaTeX 2.09 “options” conflate two sorts of things — options for the class (such as 11pt, fleqn), and packages to be loaded. So:

\documentstyle[11pt,verbatim]{article}

should become:

\documentclass[11pt]{article}
\usepackage{verbatim}

because 11pt happens to be a class option, while verbatim is a package.

There's no simple way to work out what are class options under LaTeX 2.09; for article, the list includes 10pt, 11pt, 12pt, draft, fleqn, leqno, twocolumn and twoside — anything else must be a package.

Your document may well “just work” after changes like those above; if not, you should think through what you're trying to do, and consult documentation on how to do it — there are lots of free tutorials to help you on your way, if you don't have access to a LaTeX manual of any sort.


Le message complet est très détaillé:

          Entering LaTeX 2.09 COMPATIBILITY MODE
 *************************************************************
    !!WARNING!!    !!WARNING!!    !!WARNING!!    !!WARNING!!   
 
 This mode attempts to provide an emulation of the LaTeX 2.09
 author environment so that OLD documents can be successfully
 processed. It should NOT be used for NEW documents!
 
 New documents should use Standard LaTeX conventions and start
 with the \documentclass command.
 
 Compatibility mode is UNLIKELY TO WORK with LaTeX 2.09 style
 files that change any internal macros, especially not with
 those that change the FONT SELECTION or OUTPUT ROUTINES.
 
 Therefore such style files MUST BE UPDATED to use
          Current Standard LaTeX: LaTeX2e.
 If you suspect that you may be using such a style file, which
 is probably very, very old by now, then you should attempt to
 get it updated by sending a copy of this error message to the
 author of that file.
 *************************************************************

FIXME À traduire.



Source: Entering compatibility mode

2_programmation/erreurs/e/entering_compatibility_mode.1616254741.txt.gz · Dernière modification: 2021/03/20 16:39 par jejust
CC Attribution-Share Alike 4.0 International
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0