Que signifie le message: « fixltx2e is not required with releases after 2015 »?

  • Message: fixltx2e is not required with releases after 2015
  • Origine: Extension fixltx2e et LaTeX.

Pendant longtemps, des fonctionnalités considérées comme manquantes dans le noyau LaTeX, mais qui auraient fait perdre la compatibilité avec les anciens documents, ont été fournies sous forme de l'extension fixltx2e.

Quelques exemples de ces fonctionnalités:

En 2015, toutes les corrections fournies par fixltx2e ont été intégrées à LaTeX, donc il n'y a plus besoin de charger cette extension. Si un document fait encore appel à elle, cela n'empêche pas la compilation, mais vous pouvez lire cet avertissement dans le log:

Package fixltx2e Warning: fixltx2e is not required with releases after 2015
(fixltx2e)                All fixes are now in the LaTeX kernel.
(fixltx2e)                See the latexrelease package for details.

Mécanisme de compatibilité

À partir de 2015, la compatibilité complète de LaTeX de chaque nouvelle version avec les versions précédentes n'a donc plus été automatiquement garantie.

Mais si vous avez besoin de compiler un document ancien, qui utilisait des « fonctionnalités » antérieures à la version dont vous disposez, vous avez depuis 2015 la possibilité d'utiliser l'extension latexrelease, qui restaure le comportement des versions précédentes de LaTeX.

Cette extention se charge avant la commande \documentclass, et prend en option la date de la version de LaTeX que l'on souhaite émuler. Ainsi en commençant votre document par:

\RequirePackage[2014/05/01]{latexrelease}
\documentclass{article}

vous allez le compiler comme si vous utilisiez la version de LaTeX de mai 2014 (donc avant l'intégration de fixltx2e au noyau).

En pratique, ça ne sert à rien de remonter avant 2014/05/01, car justement le noyau a été extrêmement stable jusque là, et vous utiliserez plutôt des dates comprises entre 2014 et le moment présent.

Sources:

2_programmation/erreurs/f/fixltx2e_is_not_required.txt · Dernière modification: 2021/06/08 22:25 par jejust
CC Attribution-Share Alike 4.0 International
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0